
1

Transient characterization using the 
Virtual Observatory

Authors: Miriam Cortés-Contreras, Enrique Solano. CAB (INTA-CSIC). Spanish Virtual Observatory 
(SVO).

27
th 

January 2022

NOTE: The tutorial has been tested using Firefox v89.0.2 (64-bit).

■ Scientific background: Transients can be defined as astrophysical phenomena whose
duration is significantly lower than the typical timescale of the stellar and galactic
evolution (from seconds to years in contrast to millions or billions of years). Supernovae,
novae, gamma-ray burst,..., are some examples of transient events. In most cases, a
fast, multiwavelength characterization  is required to properly  understand the true nature
of the transient. Follow-up observations made by both professional and amateur
astronomers using ground- and space-based facilities are key to achieve this goal.

Here we propose an alternative approach using the existing information in astronomical
archives and benefiting from the advantages that the Virtual Observatory offers in terms of
discovery, access and analysis of astronomical data. Using TOPCAT, Vizier and SPLAT-
VO, and two services developed in the framework  of  the  Spanish  Virtual  Observatory
(SVO Discovery Tool and VOSA) we  will  validate  and  characterize  a   cataclysmic
variable identified by the Gaia Science Alerts project. Cataclysmic variable stars (CVs) are
interacting binary systems composed by a white dwarf that accretes material from a
companion star. Because of its accretting nature, the system irregularly presents an
important increase of brightness and  then drop back down to a quiescent state.

Cataclysmic variable (source: Wikipedia)

■ Workflow:

1. Target  selection.  From  the  Gaia  Science  Alerts  project  we  will  select  an  object
classified as “unknown” and suspect of being a cataclysmic variable:

● Open your web browser and go to: h  tt  p  ://  gsaweb  .  as  t.  cam  .  ac  .  uk  /  aler  t  s  /  aler  t  sindex      

● In the search box (top right) type “Gaia19fdn”. This object has been classified
as unknown and has the following statement under the Comment column:
“Gaia source coincident with CV candidate brightens by more than 1 mag”.
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● Click on the name “gaia19fdn” (column “Name”). A new tab will open with a file card
containing information like the coordinates and the magnitude variation over time.

2. HR diagram. Cataclysmic variables occupy the intermediate region in the Hertzsprung-
Russell diagram (HRD) between the main sequence and the white dwarf  locus.

We will draw our target in a HRD diagram using TOPCAT and the VizieR service.

● Obtaining the data:

◦ We will gather Gaia EDR3 data from the VizieR service. Open your web
browser and go to http://vizier.u-strasbg.fr/  

◦ Write “Gaia” in the Free text search and click on the Find catalogues button.

◦ Look for “Gaia EDR3 (Gaia Collaboration, 2020)” in the list of results and click  on
the VizieR button to query the VizieR table.

◦ The  query  returns  five  catalogues  for  Gaia  EDR3.  Click  on  the  first  one
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(I/350/gaiaedr3).

◦ In the Target Name (resolved by Sesame) or Position box on top left, write
the coordinates of the object: 151.31404 +19.18553. Then  change  the
target dimension to 5 arcsec and click the Submit button.

◦ Launch TOPCAT: If you downloaded the Jar file, open a terminal and type: java 
- jar topcat-full.jar & ; if you have the MacOS installation, open the TOPCAT 
application.

◦ Back to VizieR, on the top right corner of the results’ page, you will see the
text Send to VO tools. Click on the antenna  icon  below  the  text.  A
SAMP Hub Security window will pop-up. Click on Yes to authorize the
connection. Then click on Broadcast button near the  antenna  in  the
VizieR window. A table named “gaiaedr3” will be loaded in TOPCAT.
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◦ Download the file “hrdiagram.xml”. It contains the astrometric solution for more
than 46000 Gaia sources with good parallaxes and colours. We will use it as a
reference for the HRD.

● Exploring the data:

◦ In TOPCAT, load the file “hrdiagram_edr3_v2.xml”: File → Load table →
Filestore Browser. Select the file and click OK. You will see the table loaded
in the Table List box, to the left. By double clicking on it you can open the
table to make a visual inspection of its content.

◦ To plot the HRD: Graphics → Plane Plot (or click on the 11
from the left). A new window will pop up.

● Select your table “hrdiagram_edr3_v2.xml”

icon starting

● X axis will be (G-RP) (difference in magnitude in the Gaia G and 
RP bands)

● Y axis: M_G (absolute magnitude in the G band).
◦ On the left panel of this window, go to Axes → Coords and select Y Flip.

◦ The color of the sources can be changed in the Plane Plot window by clicking on
the name of the plane (hrdiagram_edr3_v2.xml; it should be highlighted in blue),
then click on Subsets (the tag in between Position and Form) and change the
red color to, for instance, light gray.

◦ In order to overplot in this HRD the gaiaedr3 source we need first to create a new
column with the absolute magnitude in the G band. For this, we will proceed as
follows:

● Click on gaiaedr3 in the Table List box of the TOPCAT main window (it
should be highlighted in blue).
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● Views → Column info (or click on the 6 icon starting from the left). A
new window (Table columns) will pop up. Click on the first icon
starting from the left (a green cross). A new window (define synthetic
column) will pop up. Name it MG and write in the Expression box:

 Gmag-5*log10(1000./plx)+5
● Click OK

◦ In the same Plane Plot window: Layers → Add Position Control. In the frame
to the right, select the table “gaiaedr3” and plot (Gmag-RPmag) on the X
axis and MG on the Y axis. The source lies between the main sequence
and the white dwarf locus, as expected for a cataclysmic variable star.

th
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2. Spectral Energy Distribution (SED). Close binary stars of different effective temperature
will present two differentiated distributions, one per each component in the system. We
will now build the SED of our target using VOSA (VO SED Analyzer).

• Open your web browser and go to: h  tt  p  ://  svo2  .  cab  .  in  t  a-csic  .  es  /t  heory  /  vosa         Log
in with your user and password if you already have an account. Complete the
registration process, otherwise. To do that, click on Register and fill in the fields
(e- mail address, name and password).

• Create a single object data file typing the coordinates of the object in the RA and
DEC boxes to the right. You can write the name of the object in the description box
(“Gaia19fdn”). Click on the Create button.

◦ RA: 151.31404
◦ DEC: +19.18553
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• Click the Continue link to keep going. You will be redirected to the initial page
with this data file selected.

• Go to Objects → Distances tab to obtain the distance to the target. Keep the search
radius at 5 arcsec. Click on Search for Obj. Distances. Distances from different
catalogs will be shown. To make the Gaia EDR3 distances the final ones, select
them using the radio button on the right and click Save Obj.  Distances.  The
distance and its error should  appear boldfaced under the Final column.

• Move to Build SEDs → VO photometry. Here we will be able to look for photometric
information of our objects in different VO archives and services. In order not to slow
down too much the tutorial, click on unmark All and select only 2MASS,  WISE,
Gaia EDR3 (Vizier), Pan-Starrs PS1 DR2, and GALEX GR6+7. Then, click
Query selected services at the bottom of the page. Once this is done, a summary
table with the VO photometry (in flux units) will appear.

• Go to Build SEDs → SED edit/visualize. This tag gives us the possibility of
visualizing/modifying the SED before the model fitting. VOSA gathers from VO
services not only the photometric information but also different metadata of
interest (Object name, observing date and information on quality). In particular,
VOSA uses the information on quality to automatically identify bad photometric
points and remove them from the fitting (see next step). Upper limits are treated
in a similar way. The user can manually override this selection of photometric
points by ticking/unticking the appropriate boxes. For this use case, do not make
any change in the SED edit/visualize section.
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● Move to Analise SEDs → Binary Fit. Different grids of theoretical models covering
different ranges of physical parameters are displayed. For this tutorial select
the “Koester WD models” and “BT-Settl (CIFIST)” for fitting the white dwarf
and the main sequence components of the system, respectively.

At the bottom of the page, in Options for this fit, select “Include model spectrum
in fit plots? (The fit process will be slower, because getting the spectra from the
VO can take some time)”. Click on Next: Select model params at the bottom of
the page.

● To save time, for BT-Settl set the logg range to 4.5 – 5.5. For Koester set the
temperatures range to 5000 – 15000 K. Click on Next: Make the fit.

A summary table will appear. Click on the Show graphs button above the table to
see the SEDs plot.
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Both components of the systems have been fitted with temperatures of 14000 K and 3400 
K for the white dwarf and the low-mass star secondary, respectively.

● To see the importance of the binary fitting, try yourself by fitting only
the white dwarf component. For this, move to the tab Analise SEDs →
Chi- square Fit instead and select the “Koester WD models” with the same
parameter restrictions. The observational SED shows an infrared excess
compared to the models due to the presence of the cool component and the
estimated effective temperature (6750 K) comes from  a poor SED fitting
and does not represent the real temperature of the white dwarf.

3. Search for spectroscopic information. Cataclysmic variables show Halpha emission due
to accretion. Let’s look for spectra of our source in VO archives to see if this feature is
present.

● Open your web browser and go to:
h  tt  p  ://  sdc  .  cab  .  in  t  a-csic  .  es  /SVO  Discovery  T  ool  /         The SVO Discovery Tool will help
you getting basic information like physical parameters and photometry in the
VizieR  service, as well  as images and spectra in all the Virtual  Observatory.

● Copy the coordinates of the object in the List of object coordinates box:
151.31404 +19.18553. Select the Spectra mark box under VO Services
to obtain all available  spectra of the target. Click on Submit Query at
the bottom. A summary table shows that there are 27 spectra from the
ESO spectra service. On the bottom table, click on the number 27 to
list the spectra. They were taken with the X-Shooter instrument. You can
download them by ticking them and clicking on Download selected. They
will be saved in  a zip  file. But  you can  also  keep the window open and
launch SPLAT-VO.
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● Launch SPLAT-VO: Open a terminal and type ./splat-vo/bin/splat/splat & (or
the corresponding path in your local installation).

IMPORTANT NOTE: The latest version of SPLAT-VO (v3.15.1) was compiled
with java 8 (Java SE 8 [1.8.0_221]). Higher java versions may lead installation
errors and/or malfunctioning of the application. Check your java version (“java -
version”) and, if necessary, change it to java 8.

● Go back to the SVO Discovery Tool and locate the spectrum named
“ADP.2015-03-03T11:28:24.310”. Click on Send to SAMP Hub to the right.
A SAMP Hub Security window will pop-up. Click on Yes to authorize the
connection. A new window will pop up in SPLAT-VO with the query of the
spectrum. Note that, if other VO tools (TOPCAT, Aladin,…) are open,
the spectrum will also send to them. It does not matter.

● Select the first line, which is the science spectrum (see the eso_category
column) and click on Download selected. The spectrum will be loaded and
listed in the Global list of spectra panel on the SPLAT-VO main window.
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● Repeat the same steps to load these two spectra: ADP.2015-03-
03T11:28:22.823 and ADP.2015-03-03T11:28:24.993. When you are done,
if you wish, you can close the auxiliary window “Starlink SPLAT-VO: Query
for VO spectra”.

● In the SPLAT-VO main window, select the first spectrum and open it: View
→Display in new plots (or double click on the name of the spectrum).
A new window will pop-up with the spectrum.

● Again in the SPLAT-VO main window, select  the  second
spectrum. In the right side of the window, at the bottom, you will
see a table that lists the active plots. Tick  the  box  under
Displayed to display it together with the previous spectrum. Do the
same with the third spectrum. You can change the colour of the
displayed spectrum in this same panel, under the selection of
columns to be displayed.
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● Go to the plot  window. Go to File → Configure (or click on the 8 icon from
the left). A new window will pop-up. Untick the Autoscale X and Autoscale Y
boxes and change the wavelength and flux ranges. Then click on the Draw
button.

◦ Lower X = 620
◦ Upper X = 680
◦ Lower Y = -10E-18
◦ Upper Y = 8E-16



This is the Halpha emission line at 656.28 nm, which shows strong 
variability  associated to the accreting process typical of cataclysmic
variables.
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